Mac

VagrantでIgnoringのエラーが出る

投稿日:2018年2月15日 更新日:

解決方法が分からず、一年以上やむなく放置していたエラーが、ようやく解消されました!

環境

MacOS High Sierra 10.13.2

Vagrant + VirtualBox

エラー内容

MacローカルのVagrant環境で、vagrant upvagrant status を実行する度、下記のエラーが出現。

エラーは表示されるがその後の処理は問題なく行われる。

試したこと

・エラーメッセージの通りにgem pristine ffi --version 1.9.10などを実行

・Vagrantをアンインストール

・gemをアンインストール

・公式サイトより最新のVagrantとVirtualBoxをインストール

・プラグインvagrant-vbguestをインストール→実行

・その他ごちゃごちゃと色々コマンド叩いてみる

 

いずれも解決に至らず。。。

エラー解決策

下記のコマンドを実行。

公式サイトよりzipファイルをダウンロードしてインストールしていたけれど、それ以前にbrewからインストールをしていたことが原因だった様子。

 

環境構築などは苦手なものでして、brewやgemなどの理解が浅いまま各種コマンド実行していたので、いつの間にやら不具合が生じてしまっていたようです(結局良く分かっていない)。

謎のnokogiriの調査に何時間費やしたことでしょう・・・orz

とりあえず、エラーが出なくなって非常にスッキリしました!

広告

広告

-Mac
-,

Copyright© おうちIT , 2018 All Rights Reserved Powered by AFFINGER4.